The filer is able to communicate if I configured LACP mode as on and port channel and ethernet port as trunk, but this is not I want. I want the LACP to be active mode.
So I configured the port channel and ethernet as access and allowed a specific vlan and configured the LACP as active. Here is how I set it up
1) Enable VPC and LACP feature on the switch ( both the switch)
NX-1#feature vpc
NX-1#feature lacp
NX-1# show system internal clis feature
4 lacp enabled
9 vpc enabled
2) Create a vpc domain on all the nexus switch. The domain id should be same. Then configure the destination peer ( mgt Ip address of the other switch) this should be done on both the switches
NX-1(config-if)# vpc domain 5
NX-1(config-vpc-domain)#peer-keepalive destination 172.25.1.xx ( This is the mgt IP address of NX-2)
3) At this point if you check the vpc status, it will show as peer-link not configured, so we have to configured the peer link
NX-1(config)# sh vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : Not configured
Peer status : peer link not configured
vPC keep-alive status : Disabled
Configuration consistency status: failed
Configuration consistency reason: vPC peer-link does not exists
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
4) Configure the peer-link. This is the link which connect both the nexus, Since i have only 1 link , i'm configuring only one link, recommended is 2 peer link between nexus. Here my peer link is eth 1/37. This link is used for high speed communication between nexus. The channel group is 100
NX-1(config)# int Ethernet1/37
NX-1(config)# switchport mode trunk
NX-1(config-if)# channel-group 100 mode active
NX-1(config-if)# interface po100
NX-1(config-if)# vpc peer-link
NX-1(config-if)# sh vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 5
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1,51,53,105,112,117,252,521,777,820,940
5) Creating a port-channel 10 and assigning to vpc10 ( on both nexus). This port channel is of type access and allows vlan 53 which is my SAN vlan.
NX-2(config)# interface port-channel 10
NX-2(config-if)# vpc 10
NX-2(config-if)# switchport mode access
NX-2(config-if)# switchport access vlan 53
NX-2(config-if)# exit
6) Assigning ports to the port channel 10 ( on both nexus). I have 2 ports on each nexus and adding those ports to the port channel 10
NX-1(config)# int eth 1/1
NX-1(config-if)# switchport mode access
NX-2(config-if)# switchport access vlan 53
NX-1(config-if)# channel-group 10 mode active
NX-2(config-if)# exit
NX-1(config)# int eth 1/2
NX-1(config-if)# switchport mode access
NX-2(config-if)# switchport access vlan 53
NX-1(config-if)# channel-group 10 mode active
NX-2(config-if)# exit
7) Check the lacp port channel status. The port channel should be up. if not delete the LACP VIF from the Netapp filer and recreate again at this point. On the Netapp side you should choose LACP
NX-1(config)# sh lacp port-channel
port-channel10
System Mac=0-5-9b-7d-d-7c
Local System Identifier=0x9c4,0-5-9b-7d-d-7c
Admin key=0x800a
Operational key=0x800a
Partner System Identifier=0x1,2-a0-98-9-74-ab
Operational key=0x1
Max delay=0
VPC ID=10
Aggregate or individual=1
Member Port List=1-2
8) Check for the VPC status
NX-1(config)# sh vpc
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
10 Po10 up success success 53
9) Check for the last part of sh int brief comand
NX-1(config)# sh int brief
--trunkated----
Port-channel VLAN Type Mode Status Reason Speed Protocol
Interface
--------------------------------------------------------------------------------
Po10 53 eth access up none a-1000(D) lacp
Po100 1 eth trunk up none a-10G(D) lacp
This is how I setup the port channel with Netapp LACP VIF. I'm not a network expert so if you found any mistake or alternative ways to enable the port channel as trunk please let me know.
If you find this useful, dont forget to leave a comment ....Happy to hear that I'm helping someone out there..
Jibby George
Thanks for the writeup. I was having trouble getting this to work myself. I have the ports and port-channel in trunk mode. Still not sure why it didn't work but since I only needed to access one VLAN I changed it to access.
ReplyDeleteWorked like a champ. Thanks for the help.